summaryrefslogtreecommitdiff
path: root/main.spec
diff options
context:
space:
mode:
authornavanchauhan <navanchauhan@gmail.com>2023-05-15 20:55:53 -0600
committernavanchauhan <navanchauhan@gmail.com>2023-05-15 20:55:53 -0600
commit9151eed80c60e65526944487f9a0ab60238b9147 (patch)
tree4ce443f35870b0f82216ddf3b737637ea7bb9990 /main.spec
initial
Diffstat (limited to 'main.spec')
-rw-r--r--main.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/main.spec b/main.spec
new file mode 100644
index 0000000..0d3af44
--- /dev/null
+++ b/main.spec
@@ -0,0 +1,56 @@
+# -*- mode: python ; coding: utf-8 -*-
+
+
+block_cipher = None
+
+
+a = Analysis(
+ ['main.py'],
+ pathex=[],
+ binaries=[],
+ datas=[('assets', 'assets')],
+ hiddenimports=[],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False,
+)
+pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
+
+exe = EXE(
+ pyz,
+ a.scripts,
+ [],
+ exclude_binaries=True,
+ name='main',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ console=False,
+ disable_windowed_traceback=False,
+ argv_emulation=False,
+ target_arch=None,
+ codesign_identity=None,
+ entitlements_file=None,
+)
+coll = COLLECT(
+ exe,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ name='main',
+)
+app = BUNDLE(
+ coll,
+ name='main.app',
+ icon=None,
+ bundle_identifier=None,
+)