summaryrefslogtreecommitdiff
path: root/GCPyramid.spec
diff options
context:
space:
mode:
authornavanchauhan <navanchauhan@gmail.com>2023-06-14 21:58:00 +0530
committernavanchauhan <navanchauhan@gmail.com>2023-06-14 21:58:00 +0530
commit0a8173927c49b568909160086945176351f91411 (patch)
tree2cbeacb420cf4737c2d403d6611c6a81f1f502f5 /GCPyramid.spec
parentda4348cf62cff85defeb1249267bb4014f1f53f5 (diff)
update spec
Diffstat (limited to 'GCPyramid.spec')
-rw-r--r--GCPyramid.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/GCPyramid.spec b/GCPyramid.spec
new file mode 100644
index 0000000..d58acdb
--- /dev/null
+++ b/GCPyramid.spec
@@ -0,0 +1,55 @@
+# -*- mode: python ; coding: utf-8 -*-
+from PyInstaller.utils.hooks import collect_data_files
+
+datas = [('assets', 'assets')]
+datas += collect_data_files('sv_ttk')
+
+
+block_cipher = None
+
+
+a = Analysis(
+ ['main.py'],
+ pathex=[],
+ binaries=[],
+ datas=datas,
+ hiddenimports=[],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False,
+)
+pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
+
+exe = EXE(
+ pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name='GCPyramid',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=True,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=False,
+ disable_windowed_traceback=False,
+ argv_emulation=False,
+ target_arch='x86_64',
+ codesign_identity='16ECF592D895581CF30098ECA4234D61D323ADA7',
+ entitlements_file=None,
+ icon=['assets/logo.jpeg'],
+)
+app = BUNDLE(
+ exe,
+ name='GCPyramid.app',
+ icon='assets/logo.jpeg',
+ bundle_identifier='com.navanchauhan.gcpyramid',
+)